Cisco router can be configured as a frame relay switch,in the above picture R1 acts as a frame-relay switch which i add the pvc's between R2 and R3,R2 and R4.Frames from a Frame Relay PVC arriving on an incoming interface are switched to a Frame Relay PVC on outgoing interface. During this process, the incoming DLCI in the arriving frames is replaced by an outgoing DLCI. Frame Relay switching is performed completely in Layer 2, and the Frame Relay switch pays no attention to Layer 3 information contained within the frames. The paths taken by the switched frames are completely based on the Frame Relay route table constructed.
Configuration:
R1#sh run
Building configuration...
Current configuration : 1144 bytes
!
version 12.3
!
hostname R1
!
frame-relay switching
!
!
!
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201
frame-relay route 103 interface Serial0/2 301
!
interface Serial0/1
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
Building configuration...
Current configuration : 1144 bytes
!
version 12.3
!
hostname R1
!
frame-relay switching
!
!
!
!
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201
frame-relay route 103 interface Serial0/2 301
!
interface Serial0/1
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
no ip address
encapsulation frame-relay
serial restart-delay 0
clock rate 64000
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R2#sh run
Building configuration...
!
hostname R2
!
!
!
!
interface Serial0/0
ip address 10.0.0.1 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 10.0.0.2 102
frame-relay map ip 10.0.0.3 103
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R4#sh run
Building configuration...
hostname R4
!
!
!
!
!
interface Serial0/1
ip address 10.0.0.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 10.0.0.1 301
frame-relay map ip 10.0.0.2 301
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
R3#sh run
Building configuration...
hostname R3
!
!
!
!
!
interface Serial0/0
ip address 10.0.0.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 10.0.0.1 201
frame-relay map ip 10.0.0.3 201
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end
No comments:
Post a Comment